注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

一中大语文

与吾共语,知君有文。

 
 
 

日志

 
 

股票顶级指标公式源码  

2013-05-09 16:44:38|  分类: 投资库 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

股票顶级指标公式源码

最好的立体K线 (精品主图)源码

M1:=5;M2:=10;M3:=20;M4:=60;M5:=120;M6:=250;
MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);
MA5:MA(CLOSE,M5);
N1:=7;
VAR1:=REF(C,1);
VAR2:=SMA(MAX(C-VAR1,0),N1,1)/SMA(ABS(C-VAR1),N1,1)*1000;
VAR3:=DRAWLINE(VAR2>=HHV(VAR2,N1),VAR2,VAR2<=LLV(VAR2,N1),VAR2,1);
VAR4:=VAR2=VAR3;
VAR5:=VAR2<REF(VAR2,1);
RSV:=(C-LLV(L,25))/(HHV(HIGH,25)-LLV(L,25))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
VAR6:=(2*C+H+L)/3;{可将3该为4,信号少点}
VAR7:=EMA(EMA(EMA(VAR6,4),4),4);{可将3该为4,信号少点}
VAR8:=(VAR7-REF(VAR7,1))/REF(VAR7,1)*100;
VAR9:=MA(VAR8,3)+0.03;
VAR10:=MA(VAR8,1);
KB:=EMA(C,3)-EMA(C,18);
DB:=EMA(KB,3);
AA:=BARSCOUNT(C);
AH:=HHV(H,120);
AL:=LLV(L,120);
A0:=(AH-AL)/30;
VAR2S:=(2*CLOSE+HIGH+LOW)/4;
VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4S:=LLV(LOW,5); VAR5S:=HHV(HIGH,4);
散户:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3S;
STICKLINE(KB<DB AND DB<REF(DB,1),C,OPEN,3.2,0),COLOR004400;
STICKLINE(KB<DB AND DB<REF(DB,1),C,OPEN,2.7,0),COLOR006600;
STICKLINE(KB<DB AND DB<REF(DB,1),C,OPEN,2.1,0),COLOR008800;
STICKLINE(KB<DB AND DB<REF(DB,1),C,OPEN,1.5,0),COLOR00AA00;
STICKLINE(KB<DB AND DB<REF(DB,1),C,OPEN,0.9,0),COLOR00CC00;
STICKLINE(KB<DB AND DB<REF(DB,1),C,OPEN,0.3,0),COLOR00EE00;
STICKLINE(KB>DB AND DB>REF(DB,1),C,OPEN,3.2,0),COLOR000055;
STICKLINE(KB>DB AND DB>REF(DB,1),C,OPEN,2.7,0),COLOR000077;
STICKLINE(KB>DB AND DB>REF(DB,1),C,OPEN,2.1,0),COLOR000099;
STICKLINE(KB>DB AND DB>REF(DB,1),C,OPEN,1.5,0),COLOR0000BB;
STICKLINE(KB>DB AND DB>REF(DB,1),C,OPEN,0.9,0),COLOR0000DD;
STICKLINE(KB>DB AND DB>REF(DB,1),C,OPEN,0.3,0),COLOR0000FF;
STICKLINE(CROSS(VAR9,VAR10) AND J>65,H,OPEN,3.15,0),COLORAA1100;
STICKLINE(CROSS(VAR9,VAR10) AND J>65,H,OPEN,2.45,0),COLORAA3300;
STICKLINE(CROSS(VAR9,VAR10) AND J>65,H,OPEN,1.75,0),COLORAA5500;
STICKLINE(CROSS(VAR9,VAR10) AND J>65,H,OPEN,1.05,0),COLORAA7700;
STICKLINE(CROSS(VAR9,VAR10) AND J>65,H,OPEN,0.35,0),COLORAA9900;
STICKLINE(VAR4 AND VAR5,L,OPEN,3.15,0),COLOR1111FF;
STICKLINE(VAR4 AND VAR5,L,OPEN,2.45,0),COLOR3333FF;
STICKLINE(VAR4 AND VAR5,L,OPEN,1.75,0),COLOR5555FF;
STICKLINE(VAR4 AND VAR5,L,OPEN,1.05,0),COLOR7777FF;
STICKLINE(VAR4 AND VAR5,L,OPEN,0.35,0),COLOR9999FF;
STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,3.15,0),COLOR770077;
STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,2.45,0),COLOR990099;
STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,1.75,0),COLORBB00BB;
STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,1.05,0),COLORDD00DD;
STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,0.35,0),COLORFF00FF;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,3.15,0),COLOR337777;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,2.45,0),COLOR339999;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,1.75,0),COLOR33BBBB;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,1.05,0),COLOR33DDDD;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,0.35,0),COLOR33FFFF;
STICKLINE((AA+0)/34=FLOOR((AA+0)/34),L,OPEN,3.15,1),COLORFFFFFF;
DRAWTEXT((AA+0)/34=FLOOR((AA+0)/34),L*1,'时间窗'),COLORFFFFFF;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L*1,'吸'),COLORFF00FF;
DRAWICON(CROSS(VAR9,VAR10) AND J>65,H*1,15),COLORGREEN;
DRAWTEXT(CROSS(VAR9,VAR10) AND J>65,H*1,' 卖'),COLORYELLOW;
DRAWICON(VAR4 AND VAR5,L*1,9);
DRAWTEXT(VAR4 AND VAR5,L*1,' 买')COLORFFFFFF;
DRAWTEXT(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L*1,'地量买点'),COLOR33FFFF;
出现葫芦买做个选股预警
M1:=5;M2:=10;M3:=20;M4:=60;M5:=120;M6:=250;
MA1:=MA(CLOSE,M1);
MA2:=MA(CLOSE,M2);
MA3:=MA(CLOSE,M3);
MA4:=MA(CLOSE,M4);
MA5:=MA(CLOSE,M5);
N1:=7;
VAR1:=REF(C,1);
VAR2:=SMA(MAX(C-VAR1,0),N1,1)/SMA(ABS(C-VAR1),N1,1)*1000;
VAR3:=DRAWLINE(VAR2>=HHV(VAR2,N1),VAR2,VAR2<=LLV(VAR2,N1),VAR2,1);
VAR4:=VAR2=VAR3;
VAR5:=VAR2<REF(VAR2,1);
XG:VAR4 AND VAR5;


大单动向 源码
{DDX}
JJ:=(OPEN+HIGH+LOW+CLOSE)/4;
AA:=IF(BETWEEN(C,JJ,H) OR C=O,VOL,0);
BB:=IF(BETWEEN(C,JJ,L),VOL,0);
CC:=IF(AA AND BB,0,VOL/3);
DDX:10*(AA-(BB+CC))/IF(CAPITAL<1,SUM(VOL,13),CAPITAL),LINETHICK0;
STICKLINE(DDX>0,0,DDX,2.5,0 ),COLOR0022FF;
{STICKLINE(DDX>0,0,DDX,2,0 ),COLORBB22CC;}
STICKLINE(DDX<0,0,DDX,2.5,0 ),COLORFFFF00;
DDX1:EMA(DDX,60)*60,COLOR00FFFF;
DDX2:MA(DDX1,5),COLORFF00FF;
DDX3:MA(DDX2,10),COLOR00FF00;
预警:DDX>0 AND CROSS(DDX1,DDX2) AND (CLOSE/REF(CLOSE,1)-1)*100>=3,LINETHICK0;
DRAWTEXT(预警,0,'★'),LINETHICK3,COLOR00FFFF;
{DRAWTEXT(C,1,'大单动向'),COLORFFFFFF;}
大单动向:0.5.POINTDOT,COLORBLUE;


涨跌动因 源码
{DDY}
AA:=IF(BETWEEN(C,REF(C,1),H),VOL,0);
BB:=IF(BETWEEN(C,REF(C,1),L),VOL,0);
CC:=IF(AA AND BB,0,VOL/3);
DDY:3*(AA-(BB+CC))/IF(CAPITAL<1,SUM(INDEXV,71),CAPITAL),LINETHICK0;
STICKLINE(DDY>0,0,DDY,2.5,0 ),COLORRED;
STICKLINE(DDY<0,0,DDY,2.5,0 ),COLORGREEN;
DDY1:EMA(DDY,60)*60,COLOR00FFFF;
DDY2:MA(DDY1,5),COLORFF00FF;
DDY3:MA(DDY1,10),COLOR00FF00;
预警:DDY>0 AND CROSS(DDY1,DDY3) AND (CLOSE/REF(CLOSE,1)-1)
*100>3,LINETHICK0;
DRAWTEXT(预警,0,'★'),LINETHICK3,COLOR00FFFF;
{DRAWTEXT(C>0,0,'涨跌动因'),COLORFFFFFF;}
涨跌动因:0.5,POINTDOT,COLORBLUE;

 

大单分差 源码

P1:=170;P2:=220;
CC:=IF(CAPITAL<1,INDEXV*0.618,VOL/3);
H1:=VOL/CAPITAL*100;
H2:=INDEXV/SUM(INDEXV,71)*100;
HS:=IF(CAPITAL<1,H2,H1);
JJ:=IF(CAPITAL<1,INDEXA/INDEXV/100,(OPEN+HIGH+LOW+CLOSE)/4);
AA:=IF(BETWEEN(CLOSE,JJ,HIGH) OR CLOSE=OPEN,VOL,0);
BB:=IF(BETWEEN(CLOSE,JJ,LOW) OR CLOSE<OPEN,VOL,0);
{股旁网-股票公式网站 www.GUpang.com}
DDZ:HS*(BB-(AA+CC))/(CC-(AA-BB))*P2/100,LINETHICK0;
DDZ1:HS*(BB-(AA+CC))/(CC-(AA-BB))*P1/100,LINETHICK0;
{FILLRGN}
DRAWKLINE(DDZ>DDZ1,1,DDZ,DDZ1),COLOR0000FF;
{FILLRGN}
DRAWKLINE(DDZ<DDZ1,3,DDZ,DDZ1),COLOR00FF00;
{DRAWTEXT(CLOSE>0,1,'大单分差'),COLORFFFFFF;};

 

动力线指标原码
量:=V;
换手:V/CAPITAL*100,LINETHICK0;
VAR1:=VOL/((H-L)*2-ABS(C-O));
买盘:=IF(C>O,VAR1*(H-L),IF(C<O,VAR1*((H-O)+(C-L)),VOL/2));
卖盘:=IF(C>O,0-VAR1*((H-C)+(O-L)),IF(C<O,0-VAR1*(H-L),0-VOL/2));
DLX:(买盘-(-卖盘))/量*换手,COLORAAFF3D,LINETHICK0;
STICKLINE((买盘-(-卖盘))/量*换手,DLX,0,2,0),VOLSTICK;
DLX1:SUM(DLX,6),COLORYELLOW;
DLX2:MA(DLX1,5);
DLX3:MA(DLX1,10);

 

大单比率公式

VAR1:=C-REF(C,1);
VAR2:=O-REF(O,1);
VAR3:=H-REF(H,1);
VAR4:=L-REF(L,1);
VAR5:=(VAR1+VAR2+VAR3+VAR4)/4;
{股旁网-专业指标公式网站 www.gupang.com}
机构●大户:VAR5*VOL/10000,LINETHICK0;
STICKLINE(机构●大户>0,机构●大户,0,2.3,0), COLORRED;
STICKLINE(机构●大户<0,机构●大户,0,2.3,0) ,COLORGREEN;

 

捞钱手源码(主图)

MMS:=MA(SMA((L+H+2*C)/4-REF((L+H+2*C)/4,1),5,1)/SMA(ABS((L+H+2*C)/4-REF((L+H+2*C)/4,1)),5,1)*100,1)+50;
G1:=IF(-MMS>95,0,20);
UOO:=(-(((CLOSE-LLV(CLOSE,7))/(HHV(CLOSE,7)-LLV(CLOSE,7))*100=100)>0 AND G1)+1);
KS:=(((CLOSE - EMA(CLOSE,13)) / EMA(CLOSE,13)) * (0 - 100));
KS1:=IF(BARSCOUNT(C)=1,C/10000,(1-C/SMA(C,13,1))*100);
趋势线:=EMA(((KS / 10) + EMA(CLOSE,10)),3);
AA:=-100*(趋势线-CLOSE)/趋势线;
AC:=(EMA(AA,5) );
SSL:=EMA(CLOSE,3);
MMV:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55);
MM:=MA(MMV,1);
STICKLINE(((SSL>MM)),SSL,MM,0.01,0),COLORRED;
SA:=(MM*0.985);
SS:=(MA(CLOSE,5));
DD:=(MA(CLOSE,13));
GG:=(MA(CLOSE,21));
捞钱手:IF(((SSL>MM)),MM,SA),LINETHICK2,COLORFF00FF;
{IF(SSL<MM,捞钱手,DRAWNULL),LINETHICK2,COLORFFFFFF;}
能量线:=DMA(((CLOSE + OPEN) / 2),(VOL / (SMA(VOL,4,1) *4)));
上开:=O;
上收:=C;
上高:=H;
上低:=L;
JJ:=(上开+上高+上低)/3;
A:=EMA(JJ,4);
智能黄金线:A,COLORYELLOW,LINETHICK1;
B:=REF(A,1);
STICKLINE(((SSL<MM)),捞钱手,智能黄金线,0.01,0),COLORFFFF00;
VA1:=EMA(上收,8);
VA2:=EMA(上收,20);
DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.978,'★绝佳') ,LINETHICK2,COLORRED;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'★卖');
DRAWTEXT(CROSS(VA1,VA2)AND(C>=O)AND 智能黄金线>REF(智能黄金线,1),VA1*0.97,'★买'),COLOR00FF00;
选手A:=MA(上收,3);
箱顶A:=MA(REF(HHV(上收,6),1),3);
箱底A:=MA(REF(LLV(上收,3),1),3);
T1:=MA(上收,20)>=REF(MA(上收,20),1);
T2:=CROSS(选手A,箱底A) AND 箱顶A/箱底A>100/100 AND T1;
T3:=CROSS(箱顶A,选手A) AND 箱顶A/箱底A>100/100;
选手:=MA(上收,2);
箱顶:MA(REF(HHV(上收,30),1),2),COLOR0000FF,LINETHICK2;
箱底:MA(REF(LLV(上收,30),1),2),COLOR00FF00,LINETHICK2;
T4:=CROSS(选手,箱底) AND 箱顶/箱底>110/100;
T5:=CROSS(箱顶,选手) AND 箱顶/箱底>110/100;
VAR1:=(上收-LLV(上低,27))/(HHV(上高,27)-LLV(上低,27))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
{DRAWTEXT(VAR3 >=VAR4 ,箱顶,'--中期好'),COLOR00FFFF;
DRAWTEXT(VAR3<VAR4 ,箱顶,'--中期坏'),COLORF0F000;
DRAWTEXT(A>B ,箱底,'--短期好'),COLOR00FFFF;
DRAWTEXT(A<B ,箱底,'--短期坏'),COLORF0F000;}
DRAWTEXT(CROSS(VAR3,VAR4)AND(C>=O)AND VAR3<40 AND UOO>0,LOW*0.96,'★'),COLORF00FF0;
STICKLINE(C>=O,C,O,5,0),COLORRED;
STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
STICKLINE(C<=O,C,O,5,0),COLORGREEN;
STICKLINE(C<=O,H,L,0,0),COLORFFFF00;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);  
DRAWTEXT(CROSS(买线,卖线)AND 箱顶>=REF(箱顶,1),LOW*0.95,'★跟'),COLOR00FFFF;
STICKLINE(CROSS(买线,卖线),OPEN,CLOSE,3,0),COLOR00FFFF;

 

彩色K线主图(绝佳主图)必用精品主图之一源码

彩带函数
STICKLINE(C>=O,C,O,3,0),COLOR000045;
STICKLINE(C>=O,C,O,2.5,0),COLOR000065;
STICKLINE(C>=O,C,O,2,0),COLOR000085;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;
STICKLINE(C>=O,C,O,1,0),COLOR0000C5;
STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;
STICKLINE(C>=O,H,L,0,0),COLOR0000F5;
STICKLINE(C<O,C,O,3,0),COLOR353500;
STICKLINE(C<O,C,O,2.5,0),COLOR454500;
STICKLINE(C<O,C,O,2,0),COLOR555500;
STICKLINE(C<O,C,O,1.5,0),COLOR656500;
STICKLINE(C<O,C,O,1,0),COLOR757500;
STICKLINE(C<O,C,O,0.5,0),COLOR858500;
STICKLINE(C<O,H,L,0,0),COLOR959500;
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));
短线:VAR1,COLORWHITE;
中线:VAR6,COLORYELLOW;
下跌:IF(VAR1=VAR6,VAR6,DRAWNULL),COLORGREEN;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1;
立桩量:=FILTER(TJ1,5);
TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破:=TJ2=1;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(立桩量)),REF(HIGH,BARSLAST(立桩量)),1,0),COLORCYAN;
STICKLINE(CLOSE,REF(LOW,BARSLAST(立桩量)),REF(LOW,BARSLAST(立桩量)),1,0),COLORYELLOW;
TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破;
条件成立:=FILTER(成立,3);
DRAWTEXT(条件成立,L*0.99,'成立'),COLORYELLOW;

 

买入减仓

A1:=DATE <= 13181231;
工作线:(EMA(C,14)) * A1,POINTDOT,LINETHICK4,COLORYELLOW;


AA05:MA(C,5),LINETHICK3,COLOR0099CC;
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:EMA((速度5-REF(速度5,1)),3),NODRAW;
IF(BB05>30 AND AA05>REF(AA05,1), AA05,DRAWNULL),LINETHICK2,COLORRED;
AA10:MA(C,10), LINETHICK0;
AA20:=MA(C,20);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
IF(BB05<0 AND AA05<REF(AA05,1), AA05,DRAWNULL),LINETHICK2,COLORFFFF00;
AA30:MA(C,30), LINETHICK0;
三拾日乖离率:(C-AA30)/AA30*100,NODRAW;
VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1)  AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1)  ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05<REF(AA05,1)  AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10<REF(AA10,1),10);
DRAWTEXT(加仓 ,LOW*0.98,'←-----加仓'),COLORYELLOW;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10>REF(AA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:=FILTER(MR,10);
DRAWTEXT(减仓,HIGH*1.02,'←减仓'),COLORCYAN;
DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
VAR5:=CROSS(CCI,-100);
VAR6:=CCI>=200;
DRAWTEXT(VAR6,HIGH*1.02,'←----小心'),COLORYELLOW;
SJ:=VAR5;
STICKLINE(SJ,H,L,0.6,0),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(84,RSI) , HIGH,'←-----逃'),COLORGREEN;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'←---大胆搏 '),COLORYELLOW;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
生命线:EMA(X,13),LINETHICK2,COLORMAGENTA;

 

 

主力筹码 - 提供使用方法

己将主力筹码指标改编为通达信(高级版)用的指标,限于50线输出,改编时栅去了部分码,保留了核心精华。
源码如下:
{价量线主线快线}
价量:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)
,COLOR00CCFF,NODRAW;
主线:(((价量-LLV(价量,27))/(HHV(价量,27)-LLV(价量,27)))*(4))*(25)
,COLORCYAN,NODRAW;
快线:(((价量-LLV(价量,9))/(HHV(价量,9)-LLV(价量,9)))*(4))*(25)
,COLOR55AAFF,NODRAW;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K1:=SMA(RSV,3,1);
D1:=SMA(K1,3,1);

 


KK:=INTPART(K1);
DD:=INTPART(D1);
TFXXS:=KK+DD;{变异KD风险系数}
TGLXS:=(TFXXS-REF(TFXXS,1));{变异KD乖离系数:资金流向}
{红}
STICKLINE(TGLXS>0 AND TGLXS>REF(TGLXS,1),100,TGLXS+100,2.5,0),COLOR0000AA;
STICKLINE(TGLXS>0 AND TGLXS>REF(TGLXS,1),100,TGLXS+100,1.5,0),COLOR0022CC;
STICKLINE(TGLXS>0 AND TGLXS>REF(TGLXS,1),100,TGLXS+100,0.5,0),COLOR0055FF;
{粉}
STICKLINE(TGLXS<0 AND TGLXS>REF(TGLXS,1),100,TGLXS+100,2.5,0),COLORAA00BB;
STICKLINE(TGLXS<0 AND TGLXS>REF(TGLXS,1),100,TGLXS+100,1.5,0),COLORCC22BB;
STICKLINE(TGLXS<0 AND TGLXS>REF(TGLXS,1),100,TGLXS+100,0.5,0),COLORFF55BB;
{黄}
STICKLINE(TGLXS>0 AND TGLXS<=REF(TGLXS,1),100,TGLXS+100,2.5,0),COLOR00AAFF;
STICKLINE(TGLXS>0 AND TGLXS<=REF(TGLXS,1),100,TGLXS+100,1.5,0),COLOR00CCFF;
STICKLINE(TGLXS>0 AND TGLXS<=REF(TGLXS,1),100,TGLXS+100,0.5,0),COLOR00FFFF;
{蓝}
STICKLINE(TGLXS<0 AND TGLXS<=REF(TGLXS,1),100,TGLXS+100,2.5,0),COLORFF7700;
STICKLINE(TGLXS<0 AND TGLXS<=REF(TGLXS,1),100,TGLXS+100,1.5,0),COLORFFAA22;
STICKLINE(TGLXS<0 AND TGLXS<=REF(TGLXS,1),100,TGLXS+100,0.5,0),COLORFFFF55;
STICKLINE(TGLXS=0 AND REF(TGLXS,1)>=0,100,TGLXS+100,8,0),COLORBROWN;
STICKLINE(TGLXS=0 AND REF(TGLXS,1)<0,100,TGLXS+100,8,0),COLORWHITE;
ZLCM:=EMA(WINNER(CLOSE)*70,3);{主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;{散户套牢筹码系数}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{主力控盘筹码系数}
ZSHJJ:=EMA(ZSHTL,55);{散户警戒}
ZZLJJ:=EMA(ZZLKP,55);{主力警戒}
散兵坑:IF(ZZLKP<=10,ZZLKP,ZZLKP),COLORMAGENTA,NODRAW;
{散户套牢筹码}
STICKLINE(C>0,ZSHTL,ZZLKP,2,0),COLOR808080;
{散户筹码警戒}
STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,2,0),COLORC0C0C0;
{主力控盘筹码}
{粉}
STICKLINE(ZZLKP>REF(ZZLKP,1) AND ZZLKP>20,ZZLKP,20,2.5,0 ),COLORAA00BB;
STICKLINE(ZZLKP>REF(ZZLKP,1) AND ZZLKP>20,ZZLKP,20,1.5,0 ),COLORCC22BB;
STICKLINE(ZZLKP>REF(ZZLKP,1) AND ZZLKP>20,ZZLKP,20,0.5,0 ),COLOREE44BB;
{蓝}
STICKLINE(ZZLKP<=REF(ZZLKP,1) AND ZZLKP>20,ZZLKP,20,2.5,0 ),COLORFF7700;
STICKLINE(ZZLKP<=REF(ZZLKP,1) AND ZZLKP>20,ZZLKP,20,1.5,0 ),COLORFFAA22;
STICKLINE(ZZLKP<=REF(ZZLKP,1) AND ZZLKP>20,ZZLKP,20,0.5 ,0 ),COLORFFFF55;
{亮红}
STICKLINE(ZZLKP>REF(ZZLKP,1) AND ZZLKP<20,ZZLKP,0,2.5,0 ),COLOR131FFD;
STICKLINE(ZZLKP>REF(ZZLKP,1) AND ZZLKP<20,ZZLKP,0,1.5,0 ),COLOR5050FF;
STICKLINE(ZZLKP>REF(ZZLKP,1) AND ZZLKP<20,ZZLKP,0,0.5,0 ),COLOR7E7EFF;
{深蓝}
STICKLINE(ZZLKP<=REF(ZZLKP,1) AND ZZLKP<20,ZZLKP,0,2.5,0 ),COLORAA0000;
STICKLINE(ZZLKP<=REF(ZZLKP,1) AND ZZLKP<20,ZZLKP,0,1.5,0 ),COLORCC0000;
STICKLINE(ZZLKP<=REF(ZZLKP,1) AND ZZLKP<20,ZZLKP,0,0.5 ,0 ),COLORFF0000;
{主力筹码警戒}
{黄}
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,2.5,0 ),COLOR00AAFF;
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,1.5,0 ),COLOR00CCFF;
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,0.5,0 ),COLOR00FFFF;
{红}
STICKLINE(ZZLKP>ZZLJJ AND ZZLJJ>50,ZZLKP,ZZLJJ,2.5,0 ),COLOR0000AA;
STICKLINE(ZZLKP>ZZLJJ AND ZZLJJ>50,ZZLKP,ZZLJJ,1.5,0 ),COLOR0022CC;
STICKLINE(ZZLKP>ZZLJJ AND ZZLJJ>50,ZZLKP,ZZLJJ,0.5 ,0 ),COLOR0055FF;
{红}
STICKLINE(ZZLKP>ZZLJJ AND ZZLJJ<50 AND ZZLKP>50
AND ZZLJJ>REF(ZZLJJ,1),ZZLKP,50,2.5,0 ),COLOR0000AA;
STICKLINE(ZZLKP>ZZLJJ AND ZZLJJ<50 AND ZZLKP>50
AND ZZLJJ>REF(ZZLJJ,1),ZZLKP,50,1.5,0 ),COLOR0022CC;
STICKLINE(ZZLKP>ZZLJJ AND ZZLJJ<50 AND ZZLKP>50
AND ZZLJJ>REF(ZZLJJ,1),ZZLKP,50,0.5 ,0 ),COLOR0055FF;
{铸顶风险区}
{绿}
STICKLINE(ZZLKP>80,ZZLKP,ZZLKP-(ZZLKP-80)/2,2.5,0),COLOR00AA00;
STICKLINE(ZZLKP>80,ZZLKP,ZZLKP-(ZZLKP-80)/2,1.5,0),COLOR00CC00;
STICKLINE(ZZLKP>80,ZZLKP,ZZLKP-(ZZLKP-80)/2,0.5,0),COLOR00FF00;
{散兵坑}
STICKLINE(ZZLKP<=10,ZZLKP,0,5,0),COLORDD00DD;
100,COLORGREEN;
80,COLORGREEN;
{0,COLORGREEN;}
{主线快线}
价量,COLOR0CC0FF,LINETHICK2;
主线,COLOR00FFAA,LINETHICK2;
快线,LINESTICK,COLORFF68DD;
【该股票公式用法说明:】
源码上的小标题就是一种说明,这是一个很优秀的指标,100线上下的柱线显示资金进出情况,20线上灰白柱线提示散户筹码,彩se柱线提示主力筹码运行,从吸货拉升到出货(由蓝-黄-红-绿),散兵坑予示底部,20线下深蓝柱提示关注,亮红柱提示建仓。
三根线与柱线综合观察分析,可以获得极隹的买卖点。

散文佳作精选系列

优美的自由诗精选系列

精彩的咏物抒情诗系列精选系列 

成语积累与运用系列大全

病句诊断与修改训练系列大全

滴水藏海(文化)系列大全

班主任德育工作系列大全

动物世界系列大全

中国传统节日文化趣话系列大全

心理健康系列大全

思维与智慧系列大全

课堂教学技巧大全

成功的家庭教育系列博文大全

主题阅读大全

经典阅读与训练大全系列

美文自读系列大全

名家散文汇编系列大全

百万书库,一览无余

材料作文导写与佳作系列大全

命题作文导写与佳作系列大全

高考议论文方法与训练分类大全

作文素材人物类大全

美言如新系列大全

美食天地系列大全

中国传统节日文化趣话系列大全

智力游戏系列:下棋与猜谜

最值得收藏的书法系列

中华民族文化荟萃大全

现当代辞赋名篇大全

名人系列大全(作文素材)

这么美的女子,那么美的诗(64章)

最全的诗话系列

新诗选读系列大全

令人热血沸腾的精彩演讲系列

英语学习技巧大全

2013届福建山东高考语文仿真试题系列大全

福建高考名著阅读与训练系列大全

诗词鉴赏方法指导系列大全

文言文阅读与训练系列大全

现代文阅读指导与训练分类大全

2012级学生语言训练及佳作展示系列(待续)

美丽的数学系列

商业金手指系列大全


  评论这张
 
阅读(308)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017